вторник, 27 декабря 2011 г.

GRE Tunnel on Mikrotik and OpenWRT

У нас есть сторона Site1(Mikrotik) с локальной подсетью 10.1.101.0/24 и другая сторона Site2(OpenWRT) с подсетью 10.1.202.0/24. Нам нужно сделать доступ из одной локальной сети в сети в другую локальную сеть.





Site1 RouterBOARD
[user1@MikroTik] > 
/interface gre add name=myGre remote-address=192.168.90.1 local-address=192.168.80.1
[user1@MikroTik] > 
/ip address add address= 172.16.1.1/30 interface=myGre
[user1@MikroTik] > 
/ip route add dst-address=10.1.202.0/24 gateway=172.16.1.2


Site2 OpenWRT




root@OpenWrt:~# chmod -x /etc/init.d/firewall   // отключить файерволл
root@OpenWrt:~# df -h
root@OpenWrt:~# opkg update
root@OpenWrt:~# opkg install ip // установить пакет ip
root@OpenWrt:~# opkg install kmod-gre // установить пакет  kmod-gre
root@OpenWrt:~# insmod ip_gre
root@OpenWrt:~# lsmod
root@OpenWrt:~# vi /etc/init.d/tunnel // создать файл
#!/bin/sh /etc/rc.common
START=90
insmod ip_gre
ip tunnel add  myGre  mode gre local 192.168.90.1 remote 192.168.80.1 ttl 255
post-down ip tunnel del myGre  
ip link set   myGre  up
ip a a 172.168.1.2/30 dev myGre  
iptables -I FORWARD -i   myGre  -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --set-mss 1024
iptables -I FORWARD -o   myGre  -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --set-mss 1024
ip r a 10.1.101.0/24 via  172.168.1.1
root@OpenWrt:~# chmod +x /etc/init.d/tunnel
root@OpenWrt:~# /etc/init.d/tunnel enable
root@OpenWrt:~# reboot

Комментариев нет:

Отправить комментарий